Hoppa yfir valmynd

Alvarlegir veikleikar hjá Juniper Networks

19. jan. 2024

Tilkynnt var um veikleika í Junos OS og Juniper Secure Analytics (JSA) hjá Juniper Networks þar sem tveir þeirra voru metnir sem alvarlegir (e. critical). CERT-IS mælir með að uppfært sé eins fljótt og auðið er í útgáfu þar sem veikleikarnir hafa verið lagfærðir.

Juniper Networks

Junos OS SRX og EX Series

Veikleikinn CVE-2024-21591 með CVSSv3 einkunn upp á 9.8 er veikleiki í J-Web sem nær til Junos OS SRX og EX Series. Um er að ræða galla sem leyfir skrif út fyrir minni (e. out-of-bounds write) sem gefur óauðkenndum ógnaraðila færi á að framkvæma álagsárás (e. DoS attack), keyrslu á kóða (e. remote code execution) og að öðlast hæstu réttindi (e. root privileges) á tækinu [1,2].

Juniper Secure Analytics (JSA) Series

Veikleikinn CVE-2023-50164 með CVSSv3 einkunn upp á 9.8 er galli í Apache Struts kóðasafni (e. library) sem Juniper Secure Analytics (JSA) er háð. Misnotkun á veikleikanum gerir ógnaraðila kleift að hlaða upp skrám á þjónustuna til þess að keyra kóða (e. remote code execution) [3].

Eftirfarandi útgáfur eru háðar veikleikunum:

Junos OS (SRX, EX) Series: <20.4R3-S9, <21.2R3-S7, <21.3R3-S5, <21.4R3-S5, <22.1R3-S4, <22.2R3-S3, <22.3R3-S2, <22.4R2-S2, 22.4R3

Juniper Secure Analytics (JSA) Series: <7.5.0 UP7 IF04

Veikleikarnir hafa verið lagfærðir í útgáfum:

Junos OS (SRX, EX) Series: 20.4R3-S9, 21.2R3-S7, 21.3R3-S5, 21.4R3-S5, 22.1R3-S4, 22.2R3-S3, 22.3R3-S2, 22.4R2-S2, 22.4R3, 23.2R1-S1, 23.2R2, 23.4R1

Juniper Secure Analytics (JSA) Series: 7.5.0 UP7 IF04

 

Tilvísanir:

[1] https://thehackernews.com/2024/01/critical-rce-vulnerability-uncovered-in.html 
[2] https://supportportal.juniper.net/s/article/2024-01-Security-Bulletin-Junos-OS-SRX-Series-and-EX-Series-Security-Vulnerability-in-J-web-allows-a-preAuth-Remote-Code-Execution-CVE-2024-21591?language=en_US 
[3] https://supportportal.juniper.net/s/article/2024-01-Security-Bulletin-JSA-Series-Multiple-vulnerabilities-resolved?language=en_US