Hoppa yfir valmynd

Alvarlegir veikleikar í Ivanti Connect Secure, Policy Secure og Neurons for ZTA

01. feb. 2024

Tilkynnt var um nokkra alvarlega veikleika í Connect Secure, Policy Secure og Neurons for ZTA hjá Ivanti. Vitað er um tilfelli þar sem veikleikinn CVE-2024-21893 hefur verið misnotaður. CERT-IS mælir með að uppfært sé eins fljótt og auðið er í útgáfu þar sem veikleikinn hefur verið lagfærður eða útfæra þær mótvægisaðgerðir samkvæmt upplýsingum frá fyrirtæki ef á við.

Alvarlegir veikleikar (e. critical)

CVE-2024-21888
Veikleikinn CVE-2024-21888 með CVSSv3 veikleikastig upp á 8.8 er galli sem hefur áhrif á Ivanti Connect og Policy Secure. Misnotkun á veikleikanaum gerir notanda kleift að fá stjórnendaréttindi (e. admin privileges) [1,2,3].

CVE-2024-21893
Veikleikinn CVE-2024-21893 með CVSSv3 veikleikastig upp á 8.2 er galli sem hefur áhrif á Ivanti Connect og Policy Secure ásamt Ivanti Neurons for ZTA. Misnotkun á veikleikanum gerir ógnaraðila kleift að fá aðgang að takmörkuðum svæðum án auðkenningar [1,2,3].

Eftirfarandi kerfi eru veik fyrir göllunum:

Ivanti Connect Secure: 9.x, 22.x
Ivanti Policy Secure: 9.x, 22.x
Ivanti Neurons for ZTA: Ekki tekið fram

Veikleikinn hefur verið lagfærður í eftirfarandi útgáfum:

Ivanti Connect Secure: 9.1R14.4, 9.1R17.2, 9.1R18.3, 22.4R2.2, 22.5R1.1
Ivanti Neurons for ZTA: <22.6R1.3

Tilvísanir:

[1] https://www.bleepingcomputer.com/news/security/ivanti-warns-of-new-connect-secure-zero-day-exploited-in-attacks/
[2] https://thehackernews.com/2024/01/alert-ivanti-discloses-2-new-zero-day.html
[3] https://forums.ivanti.com/s/article/CVE-2024-21888-Privilege-Escalation-for-Ivanti-Connect-Secure-and-Ivanti-Policy-Secure?language=en_US