Hoppa yfir valmynd

Alvarlegir veikleikar í Linux, Cisco og VMware

08. feb. 2024

Tilkynnt var um nokkra alvarlega veikleika í Aria Operations for Networks hjá VMware, Expressway Series hjá Cisco og Shim bootloader hjá Linux. CERT-IS mælir með að uppfært sé eins fljótt og auðið er í útgáfu þar sem veikleikinn hefur verið lagfærður.  

Alvarlegir veikleikar (e. critical)

Shim Linux bootloader

Linux hefur gefið út uppfærslu fyrir Shim vegna sex veikleika þar sem einn af þeim er flokkaður sem mjög alvarlegur [1]. Veikleikinn CVE-2023-40547 með CVSSv3 veikleikastig upp á 9.8 gerir ógnaraðila kleift að senda sérútbúnar HTTP fyrirspurnir sem geta leitt til yfirtöku á kerfi (e. complete system compromise). Veikleikann er eingöngu hægt að misnota snemma á ræsingarfasa (e. early boot phase), en með því kemst ógnaraðili framhjá öllum vörnum (e. bypassing existing security mechanisms). Ekki er nóg að uppfæra Shim í nýjustu útgáfu, einnig verður að uppfæra UEFI Secure Boot DBX [2].

Cisco Expressway Series

Cisco hefur gefið út uppfærslu fyrir Expressway Series vegna þriggja veikleika sem allir eru flokkaðir sem alvarlegir. Veikleikarnir CVE-2024-20252 og CVE-2024-20254 eru með CVSSv3 veikleikastig upp á 9.8 og gera óauðkenndum ógnaraðila kleift að framkvæma fölsun á beiðnum (e. cross-site request forgery) sem getur meðal annars leitt til þess að auðkenndur notandi opni hlekk í eigu ógnaraðila sem leiðir til frekari árásar. Þriðji veikleikinn CVE-2024-20255 er með CVSSv3 veikleikastig upp á 8.2 gerir ógnaraðila einnig kleift að framkvæma fölsun á beiðnum (e. cross-site request forgery) sem getur leitt til niðritíma á þjónustu [3,4].

VMware Aria Operations for Networks

VMware hefur gefið út uppfærslu fyrir Aria Operations for Networks vegna fimm veikleika þar sem einn að þeim er flokkaður sem alvarlegur. Veikleikinn CVE-2024-22237 með CVSSv3 veikleikastig upp á 7.8 gerir auðkenndum ógnaraðila kleift að auka réttindi sín og öðlast kerfisstjóraréttindi (e. escalate privileges to gain root access) [5].


Eftirfarandi kerfi eru veik fyrir gallanum:

Shim Linux bootloader: < 15.8
Cisco Expressway Series: 14.x
VMware Aria Operations for Networks: < 6.12.0


Veikleikinn hefur verið lagfærður í eftirfarandi útgáfum:

Shim Linux bootloader:15.8
Cisco Expressway Series: 14.3.4 og 15
VMware Aria Operations for Networks: 6.12.0


Tilvísanir:

[1] https://www.openwall.com/lists/oss-security/2024/01/26/1
[2] https://www.bleepingcomputer.com/news/security/critical-flaw-in-shim-bootloader-impacts-major-linux-distros/
[3] https://www.bleepingcomputer.com/news/security/critical-cisco-bug-exposes-expressway-gateways-to-csrf-attacks/
[4] https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-expressway-csrf-KnnZDMj3#fs
[5] https://www.vmware.com/security/advisories/VMSA-2024-0002.html